Scheduled Maintenance - On Friday the 25th at 10PM EST we will be making some minor DNS changes to our server. We do not expect there to be any down time on our site, but if after this time our site does not load for you please simply clear your browser cache and restart your machine. - Thank you.
login
Join Now Access Products


Our Blog
Read the latest news from Shape5


31
Jan
2013


We are happy to announce that all of our products, with the exception of our Virtuemart specific extensions, have now been converted from Mootools to Jquery! We first announced this transition in September 2012. We decided to make this change because Jquery is now included from the core of Joomla 3.0, and Mootools is now labeled as a legacy script in Joomla 3.0+ and it is our opinion that it will eventually be removed. Mootools is still included with 3.0, but without mootools 1.2 support anymore. It is also our opinion that running two javascript libraries on the same site is not a good idea and will effect the performance of the site, and this is why we began the transition to Jquery so our products do not force your sites to load more than one javascript library.

Any extension that is listed as being compatible with Joomla 3.0 will also work with Joomla 2.5. The process is very simple. If the module is installed on a 2.5 installation then the extension will automatically use the core Mootools files from Joomla. If an extension is installed into a Joomla 3.0+ installation then it will automatically switch from Mootools to Jquery without you having to install a separate version or make any changes at all! This also means if you upgrade from 2.5 to 3.0+ in the future the extension will automatically switch for you to Jquery.

For a complete list of our products and Joomla compatibility please visit the following page:

http://www.shape5.com/joomla/product_compatability/current_joomla_product_compatability_list.html

Please note that site shapers listed as being compatible with Joomla 3.0 already include the newer versions of our extensions that will work with Jquery automatically. Any site shaper not listed as 3.0 compatible yet still contains the Mootools version only extensions at this time. We will gradually be updating these other site shapers to include the newer extensions and to be compatible with Joomla 3.0+.

Tags: UpdatesJoomla
Please Note - The comment system is not for product support. If you are in need of support please post your questions in our support forum boards and someone will be happy to assist you from there.
Thank you!

Free Vertex Template & Theme

Free Joomla Template
Are you new to Shape5 and the Vertex framework? Then download our totally free Vertex Joomla template or Wordpress theme to experience the power of the Vertex framework for yourself! This is the same framework that our club products are built off of.
  • Fully Responsive Layout
  • Integrated Bootstrap Styling
  • Easy To Upgrade Framework
  • Custom Module And Column Widths
  • SEO Optimized Layout
  • Right To Left Support
  • And Many Other Great Features!
Joomla Details:

Live Demo Learn More

Wordpress Details:

Live Demo Learn More

Become A Fan Of Shape5

Join Our Newsletter

Email:

From the Shape 5 Blog