Shape 5

Wordpress Club Themes => Modern Flavor - Club => : thaimacky December 24, 2014, 03:23:59 PM

: sub menus don't work properly on tablet
: thaimacky December 24, 2014, 03:23:59 PM
hi there,

as you can see on the attached screenshot the arrows in the main menu are not placed properly on my tablet screen (samsung galaxy 2).

like this the problems are that

a. most users won't even notice there is a submenu
b. as only this small hidden arrow opens the submenu, it is almost impossible to do so with a finger even if you know you have to hit the arrow to open it
c. if i hit just 1mm to the left or to the right then it will reload the site (or what "onclick" command ever is connected with that main menu)

like this the website is not functional - at least not on a samsung galaxy 2 tablet.

the joomla version of "modern flavor"  does not have these issues. there the arrows are placed where they should be and even more important: the whole main menu (word + arrow) will open the submenu...

do you have any solution for this?

merry x-mas


a) ok, i just realised that the issue with the arrows that somehow don't understand or accept the padding-right order from the original css seems to appear only in the original web browser that comes with the samsung tablet (which is not the best one anyways - but still lots of people use this one i guess).

b) this issue happens also in other browsers: only if i can manage to hit that small arrow in main menu it opens the submenu. it would be nice if the whole main menu container leaded to its submenu. possible?

edit again:

as it was x-mas time and (of course) there are no replies during these days i tried again to find the solution for issue b) myself.
it seems that this guy here had the same problem:,com_smf/Itemid,75/topic,34199.0/

the explanation there is:
"...when it's an actual link the arrow opens the sub page and the text still opens the link. If it's not a link, like a menu separator or a call javascript:; then the entire link (text and arrow) will open the sub..."

so, this would be perfect but although it is not a link in my case the text does not open the submenu. i tried to add "javascript:;" as an url placeholder but this will automatically be deleted in wordpress after saving the menu. is there another placeholder i should use or just leave the url open (as i did for now)?

just went live with the site here:

just to make sure: this problem happens only with "tablet screen size" when you have to click the menu in order to open the submenu. the hovering on the wide screen size works perfectly...

: Re: sub menus don't work properly on tablet
: Tristan Rineer December 29, 2014, 08:09:49 AM
I've attached a zip that has a fix; extract it and upload the whole folder to {themedir}/vertex (it should replace the vertex/s5flex_menu folder).

As for the arrow not showing, I asked Mike and this is the answer I got:

: mikek
I?m not sure why they aren?t showing for him, unless he?s not waiting for the whole page to load. I just tried my wife?s Galaxy Tab and the arrows show fine there. I don?t see anything in firebug that would prevent them from showing either.

Hopefully the mini-patch does what you need.

: Re: sub menus don't work properly on tablet
: thaimacky December 29, 2014, 12:38:19 PM
...perfect - that zip file did the trick - thks a lot!

the small issue on the galaxy tablet happens only in the original web browser that comes with the tablet (don't even know what browser it is). the arrows are showing as you can see on the screen shot in my first post. just some of them do somehow not understand the "padding-right" in the css and are right on top of the text of the main menu container. anyway, as now the whole container opens the submenu this is good enough for me....