Forum Support

Shape 5
September 20, 2021, 07:44:46 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Shape 5 Forum
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Error when instaling "Site Sharper"  (Read 329 times)
samuelrdv
Jr. Member
**
Offline Offline

Posts: 17



« on: April 06, 2010, 11:45:47 AM »


  i have this error message after instaling the site sharper:

in the top of the site:

Warning: Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference, value given in C:\xampp\htdocs\RiodeVida\libraries\joomla\cache\handler\callback.php on line 99

and this in admin area:

Warning: Parameter 1 to JHTMLGrid::access() expected to be a reference, value given in C:\xampp\htdocs\RiodeVida\libraries\joomla\html\html.php  on line 87

Warning: Parameter 1 to JHTMLGrid::checkedOut() expected to be a reference, value given in C:\xampp\htdocs\RiodeVida\libraries\joomla\html\html.php on line 87

   What this means? How can i fix that?
     

       
Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #1 on: April 06, 2010, 11:53:41 AM »

Hello, I just installed a fresh copy of the site shaper and do not see this error message anywhere. First please try reinstalling the site shaper in case there is a missing file or something is corrupted. If that does not work I will need to be able to see this on a live server, so if you can upload it to a test server I can look at it from there.
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
samuelrdv
Jr. Member
**
Offline Offline

Posts: 17



« Reply #2 on: April 06, 2010, 12:06:13 PM »



 ok. i?ll try this. should i remove the first instalation before. can i just install on another folder?
   
      tks,

  samuel


PS: sorry for my bad english
Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #3 on: April 06, 2010, 12:36:29 PM »

He would probably just delete the folder and database and start it over with a fresh install.
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
samuelrdv
Jr. Member
**
Offline Offline

Posts: 17



« Reply #4 on: April 08, 2010, 11:50:54 AM »


Mikek
 can you help-me
 i removed my site sharper and reinstalled it again. but now there much more errors messages...

in the top:

Warning: Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference, value given in C:\xampp\htdocs\riodevida1\libraries\joomla\cache\handler\callback.php on line 99

in the body:

Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Sao_Paulo' for '-3.0/no DST' instead in C:\xampp\htdocs\riodevida1\libraries\joomla\utilities\date.php  on line 198

and in the admin area:



Warning: strtotime() [function.strtotime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Sao_Paulo' for '-3.0/no DST' instead in C:\xampp\htdocs\riodevida1\libraries\joomla\utilities\date.php on line 56


Warning: mktime() [function.mktime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Sao_Paulo' for '-3.0/no DST' instead in C:\xampp\htdocs\riodevida1\libraries\joomla\utilities\date.php on line 117

Warning: strftime() [function.strftime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Sao_Paulo' for '-3.0/no DST' instead in C:\xampp\htdocs\riodevida1\libraries\joomla\utilities\date.php on line 250

Warning: Parameter 1 to JHTMLGrid::access() expected to be a reference, value given in C:\xampp\htdocs\riodevida1\libraries\joomla\html\html.php on line 87


                 Samuel
Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #5 on: April 08, 2010, 12:41:30 PM »

Hello, those are all built in functions to php and should be included. My guess is that your xampp does not have them installed for some reason. I suggest checking it on a live server to see if the errors still show.
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
samuelrdv
Jr. Member
**
Offline Offline

Posts: 17



« Reply #6 on: April 08, 2010, 01:27:27 PM »



tks man...
  i?ll try it tomorow...


     Samuel
Logged
samuelrdv
Jr. Member
**
Offline Offline

Posts: 17



« Reply #7 on: April 09, 2010, 01:08:05 PM »

Mikek,

    really the problem was in the xampp. i?ve installed wamp and now everything works fine. tks

              Samuel
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Valid XHTML 1.0! Valid CSS!
Looking for the largest variety in template designs? Look no more. Never buy 1 theme again. Signups start at just $89 for access to all of our themes.
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.