Forum Support

Shape 5
May 16, 2021, 03:42:01 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Shape 5 Forum
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: <workaround solution>ok with 1.6.0; error loading form file on 1.6.1  (Read 638 times)
peteuk
Jr. Member
**
Offline Offline

Posts: 3



« on: April 14, 2011, 10:21:20 AM »

<update - I know what the problem is now - workaround solution below>

Am getting the following error when I click on the intrigue template from Template Manager: Styles in Administrator (this would be where I access the colour/width params)

Quote
500 - An error has occurred.

Error loading form file

If I make the template default, the front end says:
Quote
The template for this display is not available. Please contact a Site administrator.

I installed Joomla 1.6.1 on localhost (no sample data)
I downloaded and unzipped Shape5_Intrigue_template_16.zip and put Shape5_Intrigue_template_16 into the template folder of my installation and did Extensions > Discover > Install
Install seemed successful but template is throwing the error when trying to access the style params as described.

Previously (this worked fine)...
I downloaded SiteShaper_Shape5_Intrigue_16.zip which includes Joomla 1.6.0
I unzipped and installed that with sample data on localhost and all works fine.

I have the 2 sites sat side by side on my localhost (different sitenames and DB names), the 1.6.0 version works fine but with 1.6.1 it does not.

Have I done something wrong or is there a problem with using with 1.6.1 ?

Thanks

Pete

<Workaround Solution>

The problem is caused by a discrepancy between the template folder name and the template name as stored in the Database Table jos_template_styles. (Joomla.org forum helped me figure this out as it is a problem with several templates not just this one).

It seems that for Joomla v1.6.1 the names must match but for 1.6.0 they don't?Huh

The workaround solution is to either; prior to running Discover, rename the template folder in this case from Shape5_Intrigue_template_16 to Shape5_Intrigue
or after Discover & install, update the template name in the jos_template_styles table (I used phpMyAdmin) from Shape5_Intrigue to Shape5_Intrigue_template_16 [update - this method still has probs due to not finding files e.g css - go with the rename folder solution]

so at least I can use the template now, but please can you check out why this is now a problem with 1.6.1 and is there a permanent fix?

thanks
Pete

 
« Last Edit: April 15, 2011, 08:21:58 AM by peteuk » Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #1 on: April 14, 2011, 02:09:51 PM »

Hello,

I've tested it locally int 1.6.1 and is working fine. What is the exact error you are receiving?
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
peteuk
Jr. Member
**
Offline Offline

Posts: 3



« Reply #2 on: April 14, 2011, 02:39:20 PM »

Hi mikek

did you have folder name different to template name? i.e. Shape5_Intrigue_template_16 and not Shape5_Intrigue
<see my updated original post with workaround solution>

I am on firefox3.6


Pete
« Last Edit: April 14, 2011, 02:41:59 PM by peteuk » Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #3 on: April 15, 2011, 07:36:05 AM »

Hello,

The folder name needs to remain as "Shape5_Intrigue", the template itself calls files from that specific name.
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
peteuk
Jr. Member
**
Offline Offline

Posts: 3



« Reply #4 on: April 15, 2011, 08:19:42 AM »

Cheers Mike,

I realised that just changing the name in the DB does solve the original error I was experiencing, however, I quickly found that it couldn't find the css while the folder was named Shape5_Intrigue_template_16. I scratched the site and started again this time renaming the folder from Shape5_Intrigue_template_16 to shape5_intrigue before I did discover/install and all working now thanks.

Just point to note is that the download unzips to the problem folder name:

Quote
I downloaded and unzipped Shape5_Intrigue_template_16.zip and put Shape5_Intrigue_template_16 into the template folder

regards
Pete
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Valid XHTML 1.0! Valid CSS!
Looking for the largest variety in template designs? Look no more. Never buy 1 theme again. Signups start at just $89 for access to all of our themes.
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.