Forum Support

Shape 5
June 16, 2021, 08:17:06 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Shape 5 Forum
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: how do you change the linked text appearance?  (Read 744 times)
juxtafras
Jr. Member
**
Offline Offline

Posts: 42



« on: September 02, 2008, 01:04:24 PM »

all text is currently the same color on my site, including text with links so no one can tell what to click for links.  how do i change the linked text to a different color?  in addition, is there a way to get the linked text to have a hover text color change as many sites have now, such as google searches at the top of the screen (such as an orange box around blue text)?

Thanks for any help!
Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #1 on: September 02, 2008, 01:54:22 PM »

For the hover you can add this to the very bottom of your template_css.css file:

a:hover, a:focus  {
   color:#333333;
   text-decoration:underline;
}

Just change the color to whatever you wish.

Then for the links add this just below that code:

a:link  {
   text-decoration:underline;
}
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
juxtafras
Jr. Member
**
Offline Offline

Posts: 42



« Reply #2 on: September 02, 2008, 11:38:42 PM »

i copied what you wrote and everything worked except for changing link color.  i'd like it to be different from the rest of the text, but it won't change regardless of what color i input.  how do i get the link color to change?

i have input the following for the link css:

a:link  {
   color: #FFA500;
   text-decoration: none;
   font-weight: bold;
   text-decoration:underline;
}

and the font is now bolded and underlined, but the link didn't change to orange.

Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #3 on: September 03, 2008, 06:54:56 AM »

Try putting it directly into the index.php file instead of the css file then. Just edit the index.php file and about 2/3 of the way down look for:

</style>

</head>


<body<?php if ($s5_loader == "yes") { ?> onload="loaded('s5_loader')"<?php } ?>>


Right above </style> enter the same css code.
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
juxtafras
Jr. Member
**
Offline Offline

Posts: 42



« Reply #4 on: September 03, 2008, 08:22:55 AM »

i don't see any of that in the index.php file.  it's werid that some links have changed color and others have not this is my site: www.poweredupgamers.com.  also, how do i remove the link for the logo so it doesn't turn completely orange when i hover over it? 

here are the index.php file's entire contents:

<?php
/**
* @version      $Id: index.php 10381 2008-06-01 03:35:53Z pasamio $
* @package      Joomla
* @copyright   Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
* @license      GNU/GPL, see LICENSE.php
* Joomla! is free software. This version may have been modified pursuant
* to the GNU General Public License, and as distributed it includes or
* is derivative of works licensed under the GNU General Public License or
* other free or open source software licenses.
* See COPYRIGHT.php for copyright notices and details.
*/

// Set flag that this is a parent file
define( '_JEXEC', 1 );

define('JPATH_BASE', dirname(__FILE__) );

define( 'DS', DIRECTORY_SEPARATOR );

require_once ( JPATH_BASE .DS.'includes'.DS.'defines.php' );
require_once ( JPATH_BASE .DS.'includes'.DS.'framework.php' );

JDEBUG ? $_PROFILER->mark( 'afterLoad' ) : null;

/**
 * CREATE THE APPLICATION
 *
 * NOTE :
 */
$mainframe =& JFactory::getApplication('site');

/**
 * INITIALISE THE APPLICATION
 *
 * NOTE :
 */
// set the language
$mainframe->initialise();

JPluginHelper::importPlugin('system');

// trigger the onAfterInitialise events
JDEBUG ? $_PROFILER->mark('afterInitialise') : null;
$mainframe->triggerEvent('onAfterInitialise');

/**
 * ROUTE THE APPLICATION
 *
 * NOTE :
 */
$mainframe->route();

// authorization
$Itemid = JRequest::getInt( 'Itemid');
$mainframe->authorize($Itemid);

// trigger the onAfterRoute events
JDEBUG ? $_PROFILER->mark('afterRoute') : null;
$mainframe->triggerEvent('onAfterRoute');

/**
 * DISPATCH THE APPLICATION
 *
 * NOTE :
 */
$option = JRequest::getCmd('option');
$mainframe->dispatch($option);

// trigger the onAfterDispatch events
JDEBUG ? $_PROFILER->mark('afterDispatch') : null;
$mainframe->triggerEvent('onAfterDispatch');

/**
 * RENDER  THE APPLICATION
 *
 * NOTE :
 */
$mainframe->render();

// trigger the onAfterRender events
JDEBUG ? $_PROFILER->mark('afterRender') : null;
$mainframe->triggerEvent('onAfterRender');

/**
 * RETURN THE RESPONSE
 */
echo JResponse::toString($mainframe->getCfg('gzip'));
Logged
juxtafras
Jr. Member
**
Offline Offline

Posts: 42



« Reply #5 on: September 03, 2008, 09:03:50 AM »

never mind...i didn't know the template had an index.php file...i thought you meant the entire site's index file...

i inserted the css the following css in the index.php file where you specified but the links are only partially changing color to orange:

a:hover, a:focus  {
   color: #000000;
   text-decoration: none;
   background-color: #FFA500;
   font-weight: bold;
   text-decoration:underline;
}

a:link  {
   color: #FFA500;
   text-decoration: none;
   font-weight: bold;
   text-decoration:underline;
}


any idea why it is acting so erraticly?
Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #6 on: September 03, 2008, 10:53:04 AM »

I'm looking at your site but I'm seeing all of them orange, which specific link are you seeing the problem with?
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
juxtafras
Jr. Member
**
Offline Offline

Posts: 42



« Reply #7 on: September 03, 2008, 01:22:49 PM »

The menu bar's Home, PS3, and Gametorial links are blue for some reason.

Some of the links at the bottom of the home page (http://www.poweredupgamers.com/index.php?option=com_content&view=frontpage&Itemid=1) are still blue such as Guitar Hero: Aerosmith, Geometry Wars 2, and Metal Gear Solid 4.

Also links in articles aren't updating to orange:
http://www.poweredupgamers.com/index.php?option=com_content&view=article&id=23:metal-gear-solid-4&catid=3:reviews&Itemid=19

see the bolded links between the images and below the 2nd image...also the table of contents links at the top of the article.

it's really weird.  i don't notice a pattern to what is updating and what isn't.
Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #8 on: September 03, 2008, 01:52:32 PM »

Try chaning :

a:link  {
   color: #FFA500;
   text-decoration: none;
   font-weight: bold;
   text-decoration:underline;
}

to:

a  {
   color: #FFA500;
   text-decoration: none;
   font-weight: bold;
   text-decoration:underline;
}
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
juxtafras
Jr. Member
**
Offline Offline

Posts: 42



« Reply #9 on: September 04, 2008, 05:57:23 AM »

http://www.poweredupgamers.com/index.php?option=com_content&view=article&id=23:metal-gear-solid-4&catid=3:reviews&Itemid=19

the links for the pages seemed to be working right now (menu and article links at bottom of page)...

all links within articles are not orange though...that's the pattern i've noticed (see links at top table of contents, in between images and bottom portion's "next" link, and read more links on the home page: http://www.poweredupgamers.com/index.php?option=com_content&view=frontpage&Itemid=1)

is there a section to update the css link properties for articles?
Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #10 on: September 04, 2008, 07:04:41 AM »

Below the code you already added in the index.php file add:

#s5_mainbody a {
color:#FFA500;
}
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #11 on: September 04, 2008, 07:05:39 AM »

I also noticed your pdf icon isn't lining up right so if you edit the template_css.css file and look for :

td.buttonheading at line 173 remove the line:

text-align:center;
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
juxtafras
Jr. Member
**
Offline Offline

Posts: 42



« Reply #12 on: September 04, 2008, 08:25:18 AM »

AWESOME!  it finally works.  thank you VERY much for your help.  it was frustrating, but now it's just how i wanted it.  without having the links a different color it was very hard to direct the eye to where to click.

thanks again
Logged
juxtafras
Jr. Member
**
Offline Offline

Posts: 42



« Reply #13 on: September 04, 2008, 12:51:14 PM »

actually just one more thing.  the login, whoisonline description texts are black in the upper right corner:
 
http://www.poweredupgamers.com/index.php?option=com_content&view=frontpage&Itemid=1

how do i change these to the same blue text color i am using throughout the remainder of the site?  i presume it invovles editing the html again, so i searched for something in there but had no idea what to change.

the site's logo is linkable but doesn't take up the entire width of the screen.  when i hover over the right blank section the entire width of the screen turns blue.  how do i prevent the hover effect on the logo?  worst case i could remove the logo link.  how would i do that?

thanks again!
« Last Edit: September 04, 2008, 01:37:12 PM by juxtafras » Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #14 on: September 04, 2008, 02:27:03 PM »

You would need to put a module style on those modules. A full list of them is found here:

http://www.shape5.com/demo/game_vision/index.php?option=com_content&task=view&id=15&Itemid=47
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Valid XHTML 1.0! Valid CSS!
Looking for the largest variety in template designs? Look no more. Never buy 1 theme again. Signups start at just $89 for access to all of our themes.
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.