Forum Support

Shape 5
May 08, 2021, 01:21:17 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Shape 5 Forum
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Update question  (Read 566 times)
gtc6000
Jr. Member
**
Offline Offline

Posts: 45



« on: January 16, 2012, 03:43:14 PM »

I am a returning member and find that my version of Joomla is pretty old (Joomla! 1.5.13 Stable [ Wojmamni Ama Baji ] 23-July-2009 04:00 GMT).   I am also using the original version of Touch of Soul.  I can't afford any downtime on my system.  Please advise in advance, what steps you would take to update joomla and my template.

http://reconciliationmin.org

Thanks
Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #1 on: January 16, 2012, 03:48:11 PM »

Hello,

Are you trying to upgrade to the newest version of 1.5 or to 1.7?
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
gtc6000
Jr. Member
**
Offline Offline

Posts: 45



« Reply #2 on: January 16, 2012, 04:19:04 PM »

What do you recommend?  Wouldn't I need to stay at the latest version for security considerations? Does this version of the TOS template smoothly migrate to 1.7? 
Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #3 on: January 17, 2012, 09:16:12 AM »

Hello,

1.7 would be your best option. However, 1.7 requires a new installation of the site, so it's pretty involved. There is a component called JUpgrade that will transfer your content over for your, but much of the site needs to be re-configured like the template settings, module settings, etc.
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
gtc6000
Jr. Member
**
Offline Offline

Posts: 45



« Reply #4 on: January 17, 2012, 03:51:04 PM »

In your opinion, it is better to start fresh in an alternate server directory and change the website pointers than to rebuild a production install over the old?
 
Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #5 on: January 17, 2012, 04:00:40 PM »

Hello,

When you use the JUpgrade component that's actually what it's doing. It will create a new folder called jupgrade in the root of your site and setup a new 1.7 installation in that folder with your content. From there it's a matter of re-installing the template and modules.

So it leaves your current site in tact, and one the new site is ready simply switch the domain to point to the new folder.
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
gtc6000
Jr. Member
**
Offline Offline

Posts: 45



« Reply #6 on: January 18, 2012, 01:12:45 PM »

Looking for more information about the upgrade, I saw the post below.  This seems to say you can go directly from 1.5 to 1.7.  What are your thoughts?

 Re: upgrading from 1.5.24 to 1.7
? Reply #1 on: November 09, 2011, 01:08:33 PM ? Quote 

--------------------------------------------------------------------------------
If you didnt try following the below, biggest thing is you have to be running 1.6.5 before upgrading to 1.7:

If you are upgrading from 1.6 be sure to read Joomla's tutorial here: http://docs.joomla.org/Upgrade_1.6.5_to_1.7. The most important thing to know is that you must be running at least 1.6.5 to perform the upgrade. We have seen many posts of people saying they have successfully upgraded from 1.6.3 straight to 1.7.0. Although it may appear to work there are a few database changes that will not take effect if you're upgrading from a version lower than 1.6.5. If you are not on 1.6.5 or 1.6.6 just use the following patch to upgrade http://joomlacode.org/gf/download/frsrelease/15378/66849/Joomla_1.6.0_to_1.6.6-Stable-Patch_Package.zip and then you can successfully upgrade to 1.7.
Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #7 on: January 18, 2012, 02:11:15 PM »

Hello,

Upgrading from 1.5 to 1.7 will always create a new installation. The post above is for going from 1.6 to 1.7.
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
osseo
Jr. Member
**
Offline Offline

Posts: 63



« Reply #8 on: January 24, 2012, 02:42:46 PM »

My question is similar - we are wondering if we should set up our new site in Joomla 2.5 or Joomla 1.7. Since Joomla 1.7 is not a LTS version, I wanted to start with 2.5, but none of the Shape 5 template is build for 2.5 yet. What should I do? and is it true Joomla 1.7 template will also works for 2.5?? Thanks!
Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #9 on: January 24, 2012, 03:21:54 PM »

Hello,

Anything 1.7 will work with 2.5. Please see the following:

http://www.shape5.com/blog/Joomla-2.5-Compatability-And-The-End-of-Joomla-1.5.html
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Valid XHTML 1.0! Valid CSS!
Looking for the largest variety in template designs? Look no more. Never buy 1 theme again. Signups start at just $89 for access to all of our themes.
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.