Forum Support

 
Advanced Search


New Posts
FAQs for Wordpress
If you have a question about Wordpress products please read through a list of our most commonly asked questions here.
[1]

Offline beachman
Free Member
Posts: 33
Posted on: April 07, 2013, 10:16:08 AM

Hello,

installed the Sportsnation Template and it corrupeted my whole server. It shows

Fatal error: Call to a member function data() on a non-object in /webtree/htdocs/dom-kunden/volleyballreisen.com/wp-content/plugins/gantry/core/gantrytemplatedetails.class.php on line 246

Did I needed to install something before? Vertex? Now I can?t  access my server via Wordpress nor via FTP. What the hell happened here?

Had to contact my host to fix the mess.

Best regards
Steve
Logged

Offline Tristan Rineer
Free Member
Posts: 3858
Posted on: April 08, 2013, 06:47:08 AM

That error is a problem in the Gantry framework, not in the theme - if you look at the file path given in the error, you will see exactly where the problem is.

You shouldn't have 2 frameworks installed at the same time; Vertex is built into the theme - if you deactivate Gantry before activating the theme, it should be fine.
Logged

Offline beachman
Free Member
Posts: 33
Posted on: April 08, 2013, 02:25:31 PM

Thanks Tristan,

but now I have the next problem.

At the theme options it shows me this

/webtree/htdocs/dom-kunden/volleyballreisen.com/wp-content/uploads/vertex.json is not writable or missing.
Please ensure that it is writable before saving.
You may need to increase the chmod permission settings to 775 of this file, you can do this through any standard ftp agent.

[NOTE: If the theme was just installed, saving the theme options for the first time should create the file and remove this message]

I tried the last thing - it didn?t work and I don?t know how to the first thing with increasing the chmod permission settings. Right now I see black fields covering the area where I should be able to change the template specifics etc.



Thanks for your help - again.

Steve

« Last Edit: April 09, 2013, 04:01:26 AM by beachman »
Logged

Offline Tristan Rineer
Free Member
Posts: 3858
Posted on: April 09, 2013, 08:20:28 AM

Can you tell me what host you're using?  The help bubbles covering the inputs in the admin is a problem that's been mentioned to me only a couple other times, both times, there was no reason for it, but it fixed itself when the members changed hosting providers.

As for the vertex.json issue, you just need to use your FTP client (I recommend FileZilla) to change the permissions of the wp-content folder to a minimum of 655, possibly even 775:

- navigate to your wordpress folder in FileZilla
- right-click on the wp-content folder
- click permissions
- and set the necessary permissions (making sure to apply to all files and folders recursively)
Logged

Offline beachman
Free Member
Posts: 33
Posted on: April 09, 2013, 01:49:40 PM

Hi Tristan,

I have a very good and professional host and won?t change it.  I see no reason. With my other website where I choosed the Sienna wordpress template I had the same problem, but there I could save it like it said after the first time and there were no black fields left. Why does it work there and not with the SportsNation.

Would it make sense if I allow you to check under the hood and you can see yourself?

Best regards
Steve
Logged

Offline Tristan Rineer
Free Member
Posts: 3858
Posted on: April 10, 2013, 04:41:11 AM

If all it took was saving the settings to fix it, I would first suggest copying the vertex.json from the theme folder to the wp-content/uploads folder and seeing if that fixes things. 

You should also make sure the file permissions are correct by using the steps I listed in my previous response.
Logged

Offline beachman
Free Member
Posts: 33
Posted on: April 10, 2013, 03:18:00 PM

I did everything you said, but the black shadows over the controls stayed black. I can?t change any parameters. I checked my other backend with the sienna template. There is no such a problem, but of course there you can?t change so many things like with the sportsnation theme. What else I or my host can look out for?  I even downloaded the files again. Deleted the theme and installed it new. It stays the same. And it just can?t be the host, because with every other website if Joomla or Wordpress I never had such problems. I really wanted to use the Sportsnation theme, but I have to check out another one on the weekend and see if the same problem occurs with them as well. Then I might know for sure if it is the server or your files.

Steve
Logged

Offline Tristan Rineer
Free Member
Posts: 3858
Posted on: April 11, 2013, 07:03:27 AM

What are you using to upload?  I recommend FileZilla, and you need to make sure the transfer mode (Transfer->Transfer Type) is set to binary.  The other modes can corrupt files.

As I said before, I've only seen 2 other people with this problem; including you, all 3 times have been on different releases.  I didn't write the admin code, but when I had Dave look at one of the sites that was having the issue, he couldn't find anything in the code that would cause the problem, and the member switched hosts a couple days later, which apparently fixed it.

I'm not suggesting leaving your host, but it may be a server setting that's preventing the admin javascript from loading correctly; I just have no idea what that setting might be.
Logged
[1]

Jump to:  


Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Page created in 0.026 seconds with 22 queries.
Need some help getting your site up and running? Be sure to check out our tutorials area, post on the forum or hire us
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.