Forum Support

 
Advanced Search


New Posts
FAQs for Wordpress
If you have a question about Wordpress products please read through a list of our most commonly asked questions here.
[1]

Offline chesinc
Free Member
Posts: 8

I'm a new Shape5 user and just installed the siteshaper for the Compassion theme for Wordpress.

Everything seems to be working (after I saved the Permalinks setting once) *except* for the back-end page "Shape 5 Theme".  The problem  seems to do with the hover tool-tips.

The big message in blue at the top says "Make sure to hover your mouse over each title in this column for a full description of what each field does."  But for me, hovering doesn't do anything.  Instead, I see all the tool-tip text overlaying the fields themselves ALL THE TIME, such that I can't enter anything in the fields or choose any of the pull-down options.

I've checked this in both Chrome and Firefox -- same issue.

Any help would be greatly appreciated!

Thank you,

Andrew
Logged

Offline chesinc
Free Member
Posts: 8

I also noticed that in the front end the menus are not behaving correctly.  The bottom half of the main menu item text gets cut off when hovering to show the sub-menus.  And on some pages the secondary menus are not selectable -- the page reloads when I try to click them.

Perhaps these issues and the one I started this thread with all point to a missing or bad CSS file?

Please help!

Thank you,

Andrew
Logged

Offline Tristan Rineer
Free Member
Posts: 3858

Is it possible that something didn't upload correctly?  I would suggest setting your FTP client (I recommend FileZilla) to forced "binary" transfer mode; sometimes the auto/ASCII modes can corrupt files.

You can also try just downloading the standalone theme zip and overwriting the theme folder, rather than replacing all of your WP folder.
Logged

Offline chesinc
Free Member
Posts: 8

Hi Tristan,

I appreciate the response.  I tried uploading & overwriting the theme files 3 different times using 3 different methods (including the Filezilla binary transfer method you recommended).  There is no change.

I've attached screenshots of the problems I'm seeing:

1) Back-end error:  The Shape5 Compassion Theme options page is broken such that I can't edit the fields or get rid of the tool-tip overlays on the fields.

2) Front-end error:  The main nav bar text gets cut half-off when hovering and displaying the sub-menu items.

Would you have any other ideas about what's causing this and/or how to fix it?

I'm completely stuck since I can't configure any of the Compassion Theme options at the moment.

Thanks so much for your help!

Andrew
Logged

Offline Tristan Rineer
Free Member
Posts: 3858

The issue with the menu is a conflict with the WP admin bar; if you're logged out or have the admin bar disabled in your user settings, it won't happen.  The problem is that it's a random error and it can happen on one site and not another, even if both are using the same theme.

You can try adding the following code to the end of vertex/css_and_js.php to see if that fixes it for you:
Code:
<?php if(is_admin_bar_showing()&&is_home()){ ?>
<style>
#subMenusContainer{top:28px;}
.s5_sub_wrap_lower, .s5_sub_wrap_lower_rtl {margin-top: -28px;}</style><?php ?>

The issue with the admin seems to be a server-specific problem.  There have been a very small number of people who have had that issue with that version of the admin, but every time it has happened, the problem disappeared when they either switched hosts, or reinstalled the site from scratch.

If you can provide login and FTP information, I'll pass it on to Dave (he wrote the code for the admin) and we'll see what we can do.
Logged

Offline chesinc
Free Member
Posts: 8

Hi Tristan,

I performed a full re-installation of the SIteShaper for the Compassion theme, and I still have the same problem in the Admin panel.

Please do see if you can fix this.

I'll send you the login info via a private message.

Thank you,

Andrew
Logged

Offline Tristan Rineer
Free Member
Posts: 3858

I've passed the information on to Dave, he said he'll be taking a look at it when he gets a chance.
Logged

Offline chesinc
Free Member
Posts: 8

Hi Tristan,

Thank you for passing the issue along to the right person.  Could you give me a better idea of when Dave will be able to address it?  This issue has halted progress on the client's web site.

Thank you,

Andrew
Logged

Offline Tristan Rineer
Free Member
Posts: 3858

Dave just informed me that your site is fixed now, I'll be updating the downloads soon, hopefully that will prevent anyone else from having that problem.

Thanks for your patience.
Logged

Offline chesinc
Free Member
Posts: 8

Thanks, guys!

Andrew
Logged
[1]

Jump to:  


Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Page created in 0.033 seconds with 23 queries.
Need some help getting your site up and running? Be sure to check out our tutorials area, post on the forum or hire us
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.