Forum Support

 
Advanced Search


1 2 [3] 4

Offline IvesFilm
Free Member
Posts: 49
Posted on: April 17, 2014, 12:05:10 PM

Makes sense, either way I can see how it confuses people.

Some forms just send you the email twice, for instance
« Last Edit: April 17, 2014, 12:07:08 PM by IvesFilm »
Logged

Offline gbollyvill
Free Member
Posts: 4
Posted on: August 21, 2014, 01:12:13 PM

Hello,

This is not a bug in the module, please see my post a few posts above. Your server is most likely asking for authentication, this module does not have authentication parameters, it uses the basic mail() php call.

Hi,


"I would recommend you contacting the author of the module and asking him if there is a way to use SMTP authentication for that module. Currently phpmail() is allowed on the server, but other mail providers might be blocking messages sent via this method"

That is from my provider. Please can it use SMTP and how?

Thanks.

Gbolly
Logged

Offline mikek
Free Member
Posts: 28743 WWW
Posted on: August 22, 2014, 07:49:27 AM

Hello,

The module sends through default Joomla methods. However, you have configured your email to send under Global Configuration/Server/Mail Settings is how the email will send. You can send it through php or smtp.
Logged

Offline hojermob
Free Member
Posts: 62
Posted on: September 09, 2014, 05:55:43 AM

My site is setup to run via the SMTP in the GLobal settings, does the module not send then?
Logged

Offline apexsts
Free Member
Posts: 1
Posted on: September 11, 2014, 12:24:45 PM

I was also having issues with php mail() function not because of S5 module but in my joomla with my host server.

I switched to SMTP. All of my other modules, comps worked fine with smtp except s5.

I then noticed since it is a module it never prompted for an update. Updated manually and it works fine now.

Please, make sure you have the latest S5 quick contact module. It works with SMTP just fine
« Last Edit: September 11, 2014, 12:28:47 PM by apexsts »
Logged

Offline wgcgroup
Free Member
Posts: 3
Posted on: April 14, 2016, 03:56:11 AM

Hello everyone,

I also have the problem highlighted by many and I think I figured out the problem (though I can not solve it).

PHP Mail works correctly, even SMTP but I did not understand why the emails sent by the module never came.

Until I turned off the Joomla system cache!!!

With the cache disabled emails arrive instantly. In your opinion why is this happening?

A greeting

Pier
Logged

Offline mikek
Free Member
Posts: 28743 WWW
Posted on: April 14, 2016, 08:11:08 AM

Hello,

I don't know why Joomla cache plugin would effect this. Sometimes the cache plugin will store variables on the page, which shouldn't happen as the module passes variables. I would recommend leaving it off.
Logged

Offline wgcgroup
Free Member
Posts: 3
Posted on: April 15, 2016, 02:10:00 AM

As I imagined. Do you think there is a way to exclude the module from the cache?
Logged

Offline mikek
Free Member
Posts: 28743 WWW
Posted on: April 15, 2016, 07:17:12 AM

Hello,

The Joomla cache plugin caches everything on the page, it's the plugin itself that would have to be modified to exclude specific modules, which isn't possible from our end.
Logged

Offline joyhanawa
Free Member
Posts: 43
Posted on: March 21, 2017, 09:32:12 PM

I had this problem and thought it was the module... it was me.  Don't forget to set the send this email to field in the module.
See screenshot.

Logged

Offline leila_a
Free Member
Posts: 12
Posted on: March 27, 2017, 02:23:02 PM

Hi, I use this module on http://paradisefound.ru/index.php/ru/contact-ru. It used to work fine, then stopped working. I have deleted it and created a new one, it worked fine. Now it has stopped working again, and I cannot fix it. As we are developing the site, there were a lot of changes, so I am not sure if any of these may have caused the problem, or after which change it stopped working. The form when filled out does not report any problem and says the message was sent. The mail function of Joomla has been tested and sends e-mails fine. Please help, I would love this module to work again, but also I cannot risk it stopping working all of a sudden and without any warning to the sender.

PS I tried sending a message through Explorer instead of Chrome and I get the following error message:
SMTP Error: The following recipients failed: xxx@iname.com: : Sender address rejected: not owned by user contact@xxx.eu

What does this mean? Thank you for your help.

UPDATE AND NEW QUESTION
Having read carefully through this whole thread, I realized that I have recently switched on caching on the website. Looks like turning it off helped, and the emails are now being sent. I have to note that this is not very convenient, as it affects speed reports and therefore SEO. I know this is a free module and I cannot expect you to fix this. However, I would happily buy one if you had one - if it didn't have this problem.

However, I have come across a new problem. In another form, for example here http://paradisefound.ru/index.php/ru/arenda/esplanade, I use date fields. However, when Chrome autofill function is used it messes up with those fields, by entering wrong information in the these fields (7th and 8th from the top). Is there a way to forbid Chrome autofilling this form? Thank you again.
« Last Edit: March 27, 2017, 03:28:40 PM by leila_a »
Logged

Offline mikek
Free Member
Posts: 28743 WWW
Posted on: March 27, 2017, 06:34:48 PM

Hello,

I'm not sure why caching would create a problem that just caches css and js files, unless it's caching the captcha code for some reason.

I do not know a way to forbid Chrome from auto filling, that is entirely handled by the browser.
Logged

Offline Trout
Free Member
Posts: 6
Posted on: April 13, 2017, 02:45:49 PM

Hello,

This is not a bug in the module, please see my post a few posts above. Your server is most likely asking for authentication, this module does not have authentication parameters, it uses the basic mail() php call.

I don't know what this means. (and neither do the many other people asking this question) Is there a tutorial on how to setup Quick Contact? What information do I need from GoDaddy? Thank you.
Logged

Offline mikek
Free Member
Posts: 28743 WWW
Posted on: April 14, 2017, 06:49:49 AM

Hello,

It means in the global configuration of Joomla you must setup smtp authentication, you cannot leave it on the default mail functions for most servers. Your host would have the settings for smtp.
Logged

Offline Trout
Free Member
Posts: 6
Posted on: April 18, 2017, 11:38:11 AM

Thank you Mike. I called GoDaddy and they walked me through the settings. Unfortunately it still doesn't work. They were able to send test emails through cPanel, but testing within Joomla or by using the Quick Contact doesn't work.

Can you recommend next steps? 
Logged
1 2 [3] 4

Jump to:  


Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Page created in 0.034 seconds with 20 queries.
Need some help getting your site up and running? Be sure to check out our tutorials area, post on the forum or hire us
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.