Forum Support

 
Advanced Search


New Posts
FAQs for Wordpress
If you have a question about Wordpress products please read through a list of our most commonly asked questions here.
[1]

Offline webbienl
Free Member
Posts: 3
Posted on: June 30, 2014, 03:08:39 AM

Hello everybody,

I apologize in advance if i am posting in the wrong section, I'm new to Shape 5.

Recently i started working on my own website, i made the choice to work with wordpress because it's easy to maintain a blog with it.

I chose to install a template from Shape5, the sports nation template.

The template installed fine, it was a bit of a hassle because i did not know i had to modify the wp config (would be a lot easier if you guys include this in the tutorial Cheesy) Anyway, i've now encounted a problem i cant resolve. My posts are not accessible from the site.

When i go in wordpress i see the dummy posts in the all posts section. No matter if i publish them or not, even when i press the view post button i get a 404 not found error "The requested URL /sample-post-3 was not found on this server" with the browser link displaying www."mydomainname"/sample-post-3

I use one.com webhosting, they have supplied me with a SQL database with a master account which stores all the databases for wordpress.

I tried publishing sample post 1, welcome to my home page. When i look in the SQL databse i see it is has the status publish, the post name is somple-post-1 but the guid is ?p=1352 , whilst all my other pages have either http://?page_id= or http://"mydomainname"/?

I just wanna know how i can resolve this problem so that i can publish posts from wordpress and they are viewable on my domain.

Thanks in advance, if i need to supply extra information please tell me so.

Ricardo Michalewski

Attached is a png of my site, as you can see the dummy posts are not visible.
Logged

Offline webbienl
Free Member
Posts: 3

I seem to have fixed it, there was someone else with the same problem.

I had to change "Would You Like The Component and Article Area Shown On The Frontpage?" from off to on in the theme options --> general
Logged

Offline Tristan Rineer
Free Member
Posts: 3858

Sorry about the delayed response, for some reason your post wasn't showing up for me.

You should not have needed to edit the wp-config file; what exactly did you have to do?

The error with getting a 404 for the pages is because I can't include the .htaccess file from my testing site in the shaper; all you need to do to fix that is to go to the "Settings->Permailnks" admin area and hit "Save" so WP can re-generate the .htaccess to be correct for your site.

I'm glad you were able to figure out the other issue you were having; sorry again for the delay.
« Last Edit: July 21, 2014, 10:15:12 AM by Tristan Rineer »
Logged

Offline webbienl
Free Member
Posts: 3

Sorry about the delayed response, for some reason your post wasn't showing up for me.

You should not have needed to edit the wp-config file; what exactly did you have to do?


When i put the files on my website i got the message that the sql database could not be found. So i opened the wp-config-sample and changed the following in bold:

// ** MySQL settings - You can get this info from your web host ** //
/** The name of the database for WordPress */
define('DB_NAME', 'database_name_here');

/** MySQL database username */
define('DB_USER', 'username_here');

/** MySQL database password */
define('DB_PASSWORD', 'password_here');

/** MySQL hostname */
define('DB_HOST', 'localhost');

After i saved the php to wp-config, uploaded it to my root folder and i could create my wordpress site with everything setup.
Logged

Offline Tristan Rineer
Free Member
Posts: 3858

That is very odd.  The shaper is designed to function as a full WP installer; it should have taken you through the standard WP install process and allowed you to enter the Database information as the first step of the install.  You're the first person to say anything about having the shaper not function correctly.
Logged
[1]

Jump to:  


Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Page created in 0.022 seconds with 22 queries.
Need some help getting your site up and running? Be sure to check out our tutorials area, post on the forum or hire us
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.