Forum Support

Shape 5
March 08, 2021, 04:10:53 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Shape 5 Forum
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Several Errors when installing political site shaper  (Read 651 times)
nasar5
Jr. Member
**
Offline Offline

Posts: 4



« on: November 30, 2016, 03:21:33 PM »

Hi,

I am getting a few error messages when i try to install the site shaper for political joomla

Its a fresh install, and first page i get these errors. Please see attached screenshot.

Thanks in advance
Logged
jonahh
Administrator
*****
Offline Offline

Posts: 23789



WWW
« Reply #1 on: December 01, 2016, 12:11:39 PM »

Hello,

I believe it still should install. These are more notices than errors. Some of the PHP functions should be updated and your newer version of PHP is outputting these and letting you know. Its because the Site Shaper is the older Joomla 2.5 version.
Logged

Jonah Hall
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
nasar5
Jr. Member
**
Offline Offline

Posts: 4



« Reply #2 on: December 02, 2016, 03:30:13 AM »

Hi,

Just attempted the install again now, its been about 30mins and still on the same screen just after selecting the country..

I am using php 7.

What do i need to do to install this site shaper.
Logged
nasar5
Jr. Member
**
Offline Offline

Posts: 4



« Reply #3 on: December 02, 2016, 08:32:21 AM »

I have so far commented out the following from the files below, and the installation is still stuck on 1, Language, the status indicator is whirring round and round for past 30 mins..

Changes i made are :
Registry.php
Line 342    // $result = $node->$nodes[$i] = $value;

input.php
Lines 652-656
      //$source = strtr($source, $ttr);
      // Convert decimal
      //$source = preg_replace('/&#(\d+);/me', "utf8_encode(chr(\\1))", $source); // decimal notation
      // Convert hex
      //$source = preg_replace('/&#x([a-f0-9]+);/mei', "utf8_encode(chr(0x\\1))", $source); // hex notation
      //return $source;

string.php
line 28-30
   // These are settings that can be set inside code
   //iconv_set_encoding("internal_encoding", "UTF-8");
   //iconv_set_encoding("input_encoding", "UTF-8");
   //iconv_set_encoding("output_encoding", "UTF-8");

Currently using php v7
Logged
jonahh
Administrator
*****
Offline Offline

Posts: 23789



WWW
« Reply #4 on: December 02, 2016, 01:58:21 PM »

I just remembered that php7 was not supported back then on Joomla 2.5 unfortunately. Only Joomla 3.5 and higher supports php7:

https://www.joomla.org/announcements/release-news/5654-joomla-3-5-is-here.html

You would need to use a local server like WAMP and try to find an older non php7 version. Install it and then upgrade to Joomla 3.x
Logged

Jonah Hall
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
nasar5
Jr. Member
**
Offline Offline

Posts: 4



« Reply #5 on: December 02, 2016, 03:41:52 PM »

This is really annoying because we finalised on this one template and it's not eork in as easy as it should be.

I just tried on 5.4php and dame issue again.

Can you not provide me with a version that works.
Logged
jonahh
Administrator
*****
Offline Offline

Posts: 23789



WWW
« Reply #6 on: December 05, 2016, 01:27:13 PM »

Would you be able to provide me access for the 5.4 site? I just tried on php 5.5.12 and its working fine for me.

Also are you sure you want to go with this template due to its lack of responsive capabilities? It is quite an older template and I just want to make sure you are aware of that.
Logged

Jonah Hall
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Valid XHTML 1.0! Valid CSS!
Looking for the largest variety in template designs? Look no more. Never buy 1 theme again. Signups start at just $89 for access to all of our themes.
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.