Forum Support

Shape 5
September 21, 2021, 11:13:36 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Shape 5 Forum
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Missing navigation items when viewing mobile view  (Read 307 times)
ndb4183
Jr. Member
**
Offline Offline

Posts: 7



« on: September 10, 2014, 01:39:10 PM »

Hello,

I am currently using the Oasis (Joomla 3) template.  I have created a standard main menu with a few sub menu items.  Everything looks and functions properly when viewing a wide resolution.  However, when I shrink the site down to test the responsive menu, I find several menu options missing.  These are all public links, no language options added. 

1.  I tried clearing my cache, Joomla cache, and rebuilding the menu. 
2.  I tried to recreate the menus, copy the menus, change alias, and even deleting all previously trashed menus.  I was able to get a few to work, but not all. 
3.  I searched your forum for similar issues.
4.  The only 3rd party extension that I am using is Widgetkit.  I disabled these modules and tested and my issue still exists.
5.  I looked at the template options to make sure my mobile menu is pointing to the correct menu.  I also told it to display all sub menus.

I am not sure what else to try.  I appreciate any help you can provide.  Site link below and I attached an image of the issue...

http://standrewkc.org
Logged
mikenicoll
Global Moderator
*****
Offline Offline

Posts: 20162



WWW
« Reply #1 on: September 10, 2014, 08:45:37 PM »

Hello,

In the Template Manager > Layout what are your settings for?

Levels Deep

Have you tried creating a new menu and changing the Responsive Menu assignment to a different menu?
Logged

Mike Nicoll
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
ndb4183
Jr. Member
**
Offline Offline

Posts: 7



« Reply #2 on: September 10, 2014, 09:09:58 PM »

I have the Layers Deep set to "All". 

I haven't tried creating a second menu yet.  I was hoping that I could get the Main Menu to work so I wouldn't have to create two separate menus.  Any other ideas before I go this route?

Thanks for the help.
Logged
mikenicoll
Global Moderator
*****
Offline Offline

Posts: 20162



WWW
« Reply #3 on: September 10, 2014, 09:28:08 PM »

Hello,

The only other thing I can think of would be if the menu system was corrupted in some way. That is why I suggested just creating a new menu in the back end and seeing if you assign it to the new one if the other menu elements show up correctly.
Logged

Mike Nicoll
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
ndb4183
Jr. Member
**
Offline Offline

Posts: 7



« Reply #4 on: September 12, 2014, 03:18:17 PM »

Update:

This was user error on my part.  I added some css code to hide the home button on the site.  I was basically saying hide the first child of the menu.  Doing so also made the responsive format hide the first menu section as well.  Thanks again for your help and I appreciate it.
Logged
mikenicoll
Global Moderator
*****
Offline Offline

Posts: 20162



WWW
« Reply #5 on: September 12, 2014, 05:41:26 PM »

Not a problem Smiley
Logged

Mike Nicoll
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Valid XHTML 1.0! Valid CSS!
Looking for the largest variety in template designs? Look no more. Never buy 1 theme again. Signups start at just $89 for access to all of our themes.
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.