Forum Support

 
Advanced Search


New Posts
FAQs for Wordpress
If you have a question about Wordpress products please read through a list of our most commonly asked questions here.
[1]

Offline mvhh
Free Member
Posts: 6
Posted on: November 03, 2014, 12:14:32 PM

Using Business Pro for Wordpress.  Added Advanced Recent Posts plugin but can't get titles to show when applied to page.  Also tried Recent Posts by Category plugin.  Neither will show titles when applied to any widget locations (right now trying Advanced Recent Posts on the "Left" and Recent Posts by Category on "Right".  Needless to say, there IS text in the "Title:" field in the widget admin area.  ALL of the plugins that came in the distribution of Business Pro seem to be working just fine - all showing their titles.

http://www.rompsites.net/mvhh/press/

Any ideas?

Thanks!
Logged

Offline Tristan Rineer
Free Member
Posts: 3858
Posted on: November 03, 2014, 12:18:42 PM

It appears you have the No Title style applied to those widgets; looking at the code with Firebug shows that the title is there, it's just commented out, which is what the No Title style is supposed to do.
Logged

Offline mvhh
Free Member
Posts: 6
Posted on: November 03, 2014, 12:38:13 PM

It appears you have the No Title style applied to those widgets; looking at the code with Firebug shows that the title is there, it's just commented out, which is what the No Title style is supposed to do.

There is no "No--Title" style in the widget admin.  It is set to "Default", the same as the other widgets where it's working.  (Assuming we're talking about the field: "Widget Style for advanced-recent-posts-2" for example.)  I tried setting it to Highlight1 and that didn't help.
Logged

Offline Tristan Rineer
Free Member
Posts: 3858
Posted on: November 03, 2014, 02:01:45 PM

If you PM me WP Login and FTP access details, I'll take a look at the code and see if I can figure out what's happening with your site.  There is no reason for it to be doing that, and if it's an actual bug, I need to fix it as soon as possible.
Logged

Offline mvhh
Free Member
Posts: 6
Posted on: November 03, 2014, 02:53:49 PM

If you PM me WP Login and FTP access details, I'll take a look at the code and see if I can figure out what's happening with your site.  There is no reason for it to be doing that, and if it's an actual bug, I need to fix it as soon as possible.

(Sent info via Send Us An Email on this page. Let me know if that was incorrect. Thanks!)
Logged

Offline Tristan Rineer
Free Member
Posts: 3858
Posted on: November 03, 2014, 02:57:48 PM

To send a PM through the forum, just click the little speech bubble icon under the avatar of the person you want to send the message to.
Logged

Offline Tristan Rineer
Free Member
Posts: 3858
Posted on: November 03, 2014, 03:52:59 PM

I was able to add code to fix the issues for the Advanced Recent Posts widget, but the other one cannot be fixed with the way it is currently programmed.

Both plugins are programmed in a way that prevents the custom code needed by the theme to apply widget styles.  I programmed in a "fix" a while ago that can usually override that bad programming by setting a special variable in the theme-globals.php file; it worked for the Advanced Recent Posts widget, but the Recent Posts By Category widget appears to be beyond what my override can fix.

Hopefully what I was able to do is enough to get the results you need.  Sorry I couldn't do more.

UPDATE: I was able to fix the other widget, but I had to edit the code of the plugin itself, and it will most likely break again if you ever update that plugin, so I don't recommend using it.
« Last Edit: November 03, 2014, 03:55:34 PM by Tristan Rineer »
Logged
[1]

Jump to:  


Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Page created in 0.024 seconds with 22 queries.
Need some help getting your site up and running? Be sure to check out our tutorials area, post on the forum or hire us
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.