Forum Support

Shape 5
October 18, 2021, 11:38:04 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Shape 5 Forum
 
   Home   Help Search Login Register  
Pages: [1] 2
  Print  
Author Topic: Unable to save Emusica theme settings  (Read 1385 times)
antic
Jr. Member
**
Offline Offline

Posts: 402



« on: April 28, 2015, 09:46:55 AM »

After migrating website to another host (GoDaddy) I am unable to save Theme settings. I was wandering if you would be kind enough to help me? Whenever I click the button Save within the Theme options I get redirected with the message Page Not Found. Is it a permission error or something else?
The url is https://www.kdconstructionmiami.com/
Can you please help me to resolve this issue?
Thanking you in advance!
I attached an image that illustrates the screen I am getting after I click the button Save!
Alex
« Last Edit: April 28, 2015, 12:42:17 PM by antic » Logged
Tristan Rineer
Global Moderator
*****
Offline Offline

Posts: 3858

Gravatar


« Reply #1 on: April 28, 2015, 03:24:34 PM »

When you moved the site, did the main site URL change?  WP stores the site URL in the database, so if you copied the database and didn't fix any changed paths in the database, that could easily be the cause of the problem.

As for permissions, you'll want to make sure the server has full write permissions for the wp-content/uploads folder.
Logged

Tristan Rineer
------------
Shape 5 Team



- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
antic
Jr. Member
**
Offline Offline

Posts: 402



« Reply #2 on: April 28, 2015, 11:51:16 PM »

I moved the website by using Akeeba from http://www.aca.cc.rs/kd to https://www.kdconstructionmiami.com. All the URL's were updated (post, pages, images etc...) and everything works fine except the Theme. I even tried to do Search and Replace of database by using Betters Search and Replace plugin but it did not find any occurrences of old URL.  I attached an image to this post. Do you have another solution for me? I temporary changed the permission of the wp-content/uploads folder from 755 to 777 but it did not help either.

Thanking you in advance!
Alex
Logged
Tristan Rineer
Global Moderator
*****
Offline Offline

Posts: 3858

Gravatar


« Reply #3 on: April 29, 2015, 06:20:17 AM »

The theme options save file is wp-content/uploads/cache/emusica.json - you may need to make sure that the permissions on that file are open to writing.  Does the theme options area say anything about the file being "missing or not writeable"? 
Logged

Tristan Rineer
------------
Shape 5 Team



- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
antic
Jr. Member
**
Offline Offline

Posts: 402



« Reply #4 on: April 29, 2015, 06:24:50 AM »

I just sent you a private message. Can you please check if you have received it? Thanks!
Logged
Tristan Rineer
Global Moderator
*****
Offline Offline

Posts: 3858

Gravatar


« Reply #5 on: April 29, 2015, 06:40:44 AM »

I got the message and looked at the site.  You didn't have this problem before moving the hosting?  My only thought would be that some files may have gotten corrupted when you made the transfer; if that's not the problem, then it's a problem with the new host or the way the transfer was done.
Logged

Tristan Rineer
------------
Shape 5 Team



- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
antic
Jr. Member
**
Offline Offline

Posts: 402



« Reply #6 on: April 29, 2015, 07:07:22 AM »

Ok, it may be. Should I download Emusica Theme, upload it via FTP, then apply Vertex patch and then overwrite emusica.json to retain the current theme settings? Of course in that case I should be careful about all the css files I changed to make the website look the way it is now! What do you suggest me to do?
Logged
Tristan Rineer
Global Moderator
*****
Offline Offline

Posts: 3858

Gravatar


« Reply #7 on: April 29, 2015, 07:14:08 AM »

That sounds like a good idea.  I suggest applying the patch before re-uploading the theme, just to simplify things.
Logged

Tristan Rineer
------------
Shape 5 Team



- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
antic
Jr. Member
**
Offline Offline

Posts: 402



« Reply #8 on: April 29, 2015, 09:15:08 AM »

Definitely there is a problem with the Emusica template. I deleted it from the Wordpress backend and then reinstalled it but the Saving problems still exists. After that I installed the Swapps template and there is not problem with saving the theme settings. I went back to the original website which I copied from my server to GoDaddy server, to check the Save button and I could not save the theme there either. I attached an image that illustrates the problem. This relates to the website www.aca.cc.rs/kd
The problem with the website www.kdconstructionmiami.com is Page not found when clicking the button Save and very slow load of the theme. Can you please try to resolve this issue if possible?
Thanking you in advance!
Logged
Tristan Rineer
Global Moderator
*****
Offline Offline

Posts: 3858

Gravatar


« Reply #9 on: April 29, 2015, 09:46:48 AM »

You told me earlier that you were having no issues saving any settings except the font on your test site, and then the patch fixed that problem too - what has changed since then?  It's not possible for the saving issue to be theme-specific, as the admin portion of the framework hasn't changed between Emusica and Swapps; even if you've installed the patch, the only change to the admin is the font selector, and that has nothing to do with the actual save process.

One thing that could be the problem is the PHP memory limit setting on your server.  If the PHP memory limit is too low then it won't be able to make it through the entire saving process.
Logged

Tristan Rineer
------------
Shape 5 Team



- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
antic
Jr. Member
**
Offline Offline

Posts: 402



« Reply #10 on: April 29, 2015, 09:56:17 AM »

You are right with regards to my local server. Maybe the provider changed something in the meantime. But with regards to the GoDaddy website, first I attempted to upload all the theme files via ftp and as soon as the upload was finished I checked the Save button and it did not work. After that I completely removed the theme from the backend and reinstalled it but it did not help either. I am so confused, I do not know what to do. I will try to import the sql database from my local server again to check if that corrects the problem. This is the last thing I could try! Thanks for you help so far!
Logged
antic
Jr. Member
**
Offline Offline

Posts: 402



« Reply #11 on: April 29, 2015, 12:18:30 PM »

You told me earlier that you were having no issues saving any settings except the font on your test site, and then the patch fixed that problem too - what has changed since then?  It's not possible for the saving issue to be theme-specific, as the admin portion of the framework hasn't changed between Emusica and Swapps; even if you've installed the patch, the only change to the admin is the font selector, and that has nothing to do with the actual save process.

One thing that could be the problem is the PHP memory limit setting on your server.  If the PHP memory limit is too low then it won't be able to make it through the entire saving process.

I just talked to my hosting provider and ha said nothing changed on the server in the past few days. So I was surprised that the theme cannot load even though I had no problems before. So, these are the current settings of my local server:

post_max_size   8m
upload_max_filesize  60M

cPanel PHP max POST size   55M
cPanel PHP max upload size   55M

This data proves that nothing on the server prevents the theme file from load. There must be something else! Maybe the newest patch made the problem. Can you please forward this post to your developer? I will provide the FTP parameters if necessary. You can login to the website on my server here www.aca.cc.rs/kd/wp-admin with the same user name and pass I sent you in the private message, and see the problem yourself. I doubt that Wordpress update caused the problem.  
« Last Edit: April 29, 2015, 12:52:09 PM by antic » Logged
antic
Jr. Member
**
Offline Offline

Posts: 402



« Reply #12 on: April 29, 2015, 01:27:41 PM »

The last step I performed was installing the Swapps template on my local server www.aca.cc.rs/kd. After setting it active and clicking the Shape5 Theme in the left sidebar, the theme loaded very quickly and the Save button works perfectly. I guess this is the proof there is something wrong with the Emusica theme that does not work on two different servers. Can you please help me to solve this issue?
Logged
Tristan Rineer
Global Moderator
*****
Offline Offline

Posts: 3858

Gravatar


« Reply #13 on: April 29, 2015, 02:05:35 PM »

I just installed the Emusica site shaper on 3 different testing servers, successfully saved settings in the admin, upgraded WP and applied the patch, then successfully saved settings in the admin again.

Whatever is wrong with your site is either caused by a third party plugin or a server setting.  If you have any third party plugins installed that are not included in the shaper, I suggest testing for compatibility issues by disabling them and saving settings in the theme options as you enable them one at a time until you find the one causing the problem.  If it's not a plugin causing the problem, then either something you changed before migrating your site or something else on your servers is causing the problem.
Logged

Tristan Rineer
------------
Shape 5 Team



- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
antic
Jr. Member
**
Offline Offline

Posts: 402



« Reply #14 on: April 29, 2015, 02:29:51 PM »

I must say I appreciate your help but the entire time you are telling me what is causing the problem by your opinion. Can you give me some solution? I just deactivated all plugins and nothing changed, now I cannot even open the Shape5 Theme - it loads forever - endless loop. Just to mention again this is happening on two different servers. Can you please confirm that installing the Emusica theme from scratch will solve the problem? By the way I did not used the site shaper for the installation but stand alone template!
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Valid XHTML 1.0! Valid CSS!
Looking for the largest variety in template designs? Look no more. Never buy 1 theme again. Signups start at just $89 for access to all of our themes.
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.