Forum Support

Shape 5
April 19, 2021, 12:47:48 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Shape 5 Forum
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: s5 Image Slide stoped working in module mode  (Read 716 times)
reedko
Jr. Member
**
Offline Offline

Posts: 4



« on: October 11, 2016, 03:11:32 AM »

I'm using the compassion template and it was set up with image slide in module mode, showing an imageslide_1 and imageslide_2 module with a vimeo video link and some text.  So I couldn't find where the vimeo video link was under imageslide_1 module.  It just had the words in the custom html, I expected to see the vimeo link.  Where is that?

 Then I went into the image slide module and tried changing the image, even though it was in module mode, and when I saved and reloaded , the image slide section was missing.  I can't get it to come back in module mode, but in image mode it seems to behave as expected.  I tried adding imageslide_1 and imageslide_2 positions to templateDetails.xml but still not showing up.

Thanks for any guidance on this
Logged
jonahh
Administrator
*****
Offline Offline

Posts: 23789



WWW
« Reply #1 on: October 11, 2016, 11:53:12 AM »

Hello,

Quote
So I couldn't find where the vimeo video link was under imageslide_1 module.  It just had the words in the custom html, I expected to see the vimeo link.  Where is  that?

If you are using a WYSIWYG editor on your site then you won't see the actual Vimeo link code. You can only see it by showing source code in the editor or disabling the editor.


Quote
Then I went into the image slide module and tried changing the image, even though it was in module mode, and when I saved and reloaded , the image slide section was missing.  I can't get it to come back in module mode, but in image mode it seems to behave as expecte

I'm not sure on this I would have to take a first hand look. If you can PM me FTP and Joomla login details then I can take a look for you.
Logged

Jonah Hall
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
reedko
Jr. Member
**
Offline Offline

Posts: 4



« Reply #2 on: October 13, 2016, 05:54:59 AM »

OK.  I WAS looking at the source.  I just did another fresh install of compassion and went straight to the imageslide_1 module and then looked at the html source, this is what it looks like:

<div style="float: left; width: 449px; margin-left: 8px; margin-top: 8px;"> </div>
<div style="float: left; line-height: 38px; margin-left: 29px; margin-top: 3px; text-align: right; width: 430px;">
<h1>What is our misson?</h1>


<h2 style="color: #5b5b5b;">We are <span class="blackhigh">commited to helping</span> poverty stricken communities suffering from injustices <span class="blackhigh">regain hope</span> and get their lives back together.</h2>
</div>
<div style="style: both;"> </div>

Now, in this fresh install, I went into the site shaper module,  mod_s5_imageslide,  Options, Image Settings, and copied the image from the Image 2 Location URL to the Image 1 Location URL.  I didn't change anything else, the options were still in module mode.  When I clicked Save, the image slider dissappeared and I caouldn't get it to come back.
Logged
jonahh
Administrator
*****
Offline Offline

Posts: 23789



WWW
« Reply #3 on: October 13, 2016, 01:35:48 PM »

Are you working with a WYSIWYG editor enabled? They will sometimes strip out HTML code on save. I would recommend disabling it temporarily while you add this code and save.
Logged

Jonah Hall
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
reedko
Jr. Member
**
Offline Offline

Posts: 4



« Reply #4 on: October 13, 2016, 01:59:13 PM »

One issue is I can't find the video link.   I didn't save anything, I was just looking for the vimeo link that shows up in the page and expected to see it in the Custom Html of imageslide1.  I turned off WYSIWYG to look at the source and I don't see the link.  I didn't SAVE or change anything.  The page shows a video link in the image slide module but I can't find any video link in the custom html for imageslide 1 or imageslide 2.  Am I looking in the wrong place?  Maybe you could look at that module in the Compassion theme and tell me what you see. 

The other issue is that the image slide module seems to get squeezed into one line in module mode if you do the steps I described.  I got the module to show up in module mode again by re-installing, but I still don't know what edits will cause the module mode of the image slide to effectively disappear.

Logged
jonahh
Administrator
*****
Offline Offline

Posts: 23789



WWW
« Reply #5 on: October 14, 2016, 12:16:31 PM »

I'm not sure but here is the code for the image slide. Try adding this and see if it fixes it for you. Just be sure your WYSIWYG editor is disabled:

Code:
<div style="float:left;width:449px;margin-left: 8px;margin-top: 8px;">

<div class="module_round_box-white">
<div class="s5_module_box_1">
<div class="s5_module_box_2">

<iframe src="http://player.vimeo.com/video/15204182?title=0&amp;byline=0&amp;portrait=0&amp;color=ffffff" width="429" height="251" frameborder="0"></iframe>
<div style="clear:both; height:0px"></div>
</div>
</div>
</div>


</div>
<div style="float: left;
    line-height: 38px;
    margin-left: 29px;
    margin-top: 3px;
    text-align: right;
    width: 430px;">
<h1>What is our misson?</h1>
<br>
<h2 style="color:#5b5b5b;">
We are <span class="blackhigh">commited to helping</span> poverty stricken communities suffering from injustices <span class="blackhigh">regain hope</span> and get their lives back together.</h2>
</div>
<div style="style:both;"></div>
   
Logged

Jonah Hall
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
reedko
Jr. Member
**
Offline Offline

Posts: 4



« Reply #6 on: October 14, 2016, 11:45:55 PM »

Thanks.  Yeah that's what I see when I View the source for the page.  Even though that module, mod_s5_imageslide, no longer appears on the page when its in Module Mode.
When I go into the Joomla editor in html mode it doesn't show any of this:


<div style="float:left;width:449px;margin-left: 8px;margin-top: 8px;">

<div class="module_round_box-white">
<div class="s5_module_box_1">
<div class="s5_module_box_2">

<iframe src="http://player.vimeo.com/video/15204182?title=0&amp;byline=0&amp;portrait=0&amp;color=ffffff" width="429" height="251" frameborder="0"></iframe>
<div style="clear:both; height:0px"></div>
</div>
</div>
</div>


</div>


 and nothing shows up in the imageslide section when I view the page.  So I either have to use it in image mode or reinstall Joomla and the template and avoid editing the image settings.

So you can see what the page looks like with the problem here: http://reedko.com/cbsmtest/
Logged
jonahh
Administrator
*****
Offline Offline

Posts: 23789



WWW
« Reply #7 on: October 17, 2016, 11:55:39 AM »

Quote
When I go into the Joomla editor in html mode it doesn't show any of this:

This is your issue, you need to disable the editor all together in your Joomla global configuration area and then add in the code. The editor is stripping out the code even if you use the source code view it still won't work when you save.
Logged

Jonah Hall
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Valid XHTML 1.0! Valid CSS!
Looking for the largest variety in template designs? Look no more. Never buy 1 theme again. Signups start at just $89 for access to all of our themes.
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.