Forum Support

 
Advanced Search


New Posts
FAQs for Wordpress
If you have a question about Wordpress products please read through a list of our most commonly asked questions here.
[1]

Offline mdrothert
Free Member
Posts: 199

After I install wordpress 4.1 via the Site Shaper found here:
http://www.shape5.com/component/option,com_docman/Itemid,96/task,doc_download/gid,1290/

For theme: Health Guide

I find that I hit an error when trying to login to the admin portal of wordpress.

Code:
[03-Feb-2017 20:49:46 UTC] PHP Fatal error:  Uncaught Error: Cannot create references to/from string offsets in /Users/.../wp-includes/user.php:54
Stack trace:
#0 /.../wp-login.php(775): wp_signon('', '')
#1 {main}
  thrown in /.../wp-includes/user.php on line 54

This raises a 500 http response at :
`http://localhost:8888/wp-login.php?redirect_to=http%3A%2F%2Flocalhost%3A8888%2Fwp-admin%2F&reauth=1`

while trying to use `/wp-admin`

Specs:
PHP 7.1.0
MySQL: 5.6.34
Apache: 2.2.31

Please advise how to address this issue.

« Last Edit: February 03, 2017, 03:08:23 PM by mdrothert »
Logged

Offline mdrothert
Free Member
Posts: 199

It looks as if this version of wordpress packaged with the site shaper has an inherit flaw with the most current stable version of php.

https://core.trac.wordpress.org/ticket/37071

This issue can be seen in version of 4.6 of wordpress and since the site shaper is packaged with 4.1 I assume this is the cause.
« Last Edit: February 03, 2017, 03:10:31 PM by mdrothert »
Logged

Offline Tristan Rineer
Free Member
Posts: 3858

Does the problem disappear if you update WP?

Unfortunately, I haven't been able to find a way to force WP to auto-update during the install process, so updating WP should always be the first step after installing the shaper.

I believe you can add the following code to your wp-config.php file to force an update if needed:

Code:
define( 'WP_AUTO_UPDATE_CORE', true );



[Note: I am moving this topic to the correct board; please remember in the future to post theme/plugin specific questions to the board created specifically for the theme/plugin you are asking about.]
« Last Edit: February 03, 2017, 03:20:02 PM by Tristan Rineer »
Logged

Offline mdrothert
Free Member
Posts: 199

Using the config you provided did allow for the install to work correctly.

Except now the Vertex core theme says its out of data 4.1 > 4.0

I followed the link to do the patch but after updating with the patch I get. "Template XML file " errors on every page.

I since rolled that patch back.

In addition to that I see the plugin used to inject the demo data does not bring the site any were close to the same level of data used in the demo. 

I suspected that the demo data plugin was possibly faulty due to Vertex patch not being applied but I cant get the patch to work to rule that out.
Logged

Offline Tristan Rineer
Free Member
Posts: 3858

That error means that the patch wasn't installed correctly.

Here's the easiest instructions for how to install the patch:


===============
To install the patch:

1. Download the Vertex Upgrade Patch.
2. Back up your site (just in case).
3. Copy the vertex/footer.php from the theme folder to somewhere safe (you'll be putting it back after patching).
4. Delete the vertex folder from the theme (nothing else, that is the only thing to delete).
5. Extract the zip file containing the patch, and upload it to the theme folder through FTP, choosing "overwrite" if/when prompted.
6. Copy the footer.php file (from step 3) back into the vertex folder of the theme.

That's it. 

Or, to put it a different way:
1. Back up vertex/footer.php. 
2. Delete the vertex folder, then upload the extracted patch to the theme folder. 
3. Put the footer.php file back into the vertex folder of the theme.
===============


 
Logged
[1]

Jump to:  


Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Page created in 0.022 seconds with 22 queries.
Need some help getting your site up and running? Be sure to check out our tutorials area, post on the forum or hire us
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.