Forum Support

Shape 5
October 25, 2021, 04:29:35 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Shape 5 Forum
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Help Please! Tab Show & Homepage Video not playing  (Read 470 times)
cpaice
Jr. Member
**
Offline Offline

Posts: 5



« on: February 14, 2017, 11:31:05 AM »

http://wyoparks.state.wy.us/sphst/Parks,Sites,Trails/

I'm working on creating a website using the Incline Template.  However, the Homepage video is not working properly (it plays sound but I don't see the picture). I have tried numerous videos (including videos other users are using in their templates) and I'm having the same problem.

Current test video source: http://wyomuseum.state.wy.us/Learn/Videos/nathan%20skype4.mp4

The S5 tab shows do not play on any of my pages. I have also tried just downloading the S5 Extension on another Joomla install for a different site and I wasn't able to get it to work on there either.

http://wyoparks.state.wy.us/sphst/Parks,Sites,Trails/index.php/extensions/s5-tab-show

My server is hosted locally.
Windows Web Server (r) 2008
PHP Version: 7.0.9
MySQL Server Version: 5.1
Joomla Version:  3.6.5

I have also attempted using the Microsoft SQL Server for my database to no avail.  I have double checked that I have modules published to the various Tab positions.

I can reprogram the site myself - but it seems like that kind of defeats the purpose of using a template.  Any help is much appreciated. Thanks!
Logged
mikek
Administrator
*****
Offline Offline

Posts: 28743



WWW
« Reply #1 on: February 15, 2017, 08:07:33 AM »

Hello,

I don't see the video playing at all, not even sound. It might be due to the url of your mp4 file. Files should not have a space in their names, you should remove that and then update the url. Your video is currently trying to download when I try to access it instead of playing in the browser as it should. I am not sure what is causing that. It could be a server setting, it might also have to do with the space in the name.

For the tab show issue your server is most likely running an out-dated 32bit operating system. Try modifying the following file:

modules\mod_s5_tab_show\tmpl\default.php

Find this:

$s5_tab_show_random_id = mt_rand(1000000000,9999999999);

And replace it with:

$s5_tab_show_random_id = mt_rand (1000000000, mt_getrandmax());
Logged

Mike Knott
------------
Shape 5 Team

- Need a great host for your website? We highly recommend siteground.com!


- Put your trust in the hands of our extremely qualified staff to get your job done right!


- Firebug is the most powerful web development and debugging tool, and it will save you a lot of time, frustration and forum questions:
Install Firebug
cpaice
Jr. Member
**
Offline Offline

Posts: 5



« Reply #2 on: February 15, 2017, 09:53:37 AM »

You sir, are my hero.  Thank you so much! Adjusting that one line of code fixed the video and the tab show.  I appreciate it! Cheers!

Hello,

I don't see the video playing at all, not even sound. It might be due to the url of your mp4 file. Files should not have a space in their names, you should remove that and then update the url. Your video is currently trying to download when I try to access it instead of playing in the browser as it should. I am not sure what is causing that. It could be a server setting, it might also have to do with the space in the name.

For the tab show issue your server is most likely running an out-dated 32bit operating system. Try modifying the following file:

modules\mod_s5_tab_show\tmpl\default.php

Find this:

$s5_tab_show_random_id = mt_rand(1000000000,9999999999);

And replace it with:

$s5_tab_show_random_id = mt_rand (1000000000, mt_getrandmax());
« Last Edit: February 15, 2017, 09:55:59 AM by cpaice » Logged
joyhanawa
Jr. Member
**
Offline Offline

Posts: 43



« Reply #3 on: March 09, 2017, 10:26:34 AM »

Great answer! I was just going to say it doesn't work in PHP7... can you update the site shaper with the new code?
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Valid XHTML 1.0! Valid CSS!
Looking for the largest variety in template designs? Look no more. Never buy 1 theme again. Signups start at just $89 for access to all of our themes.
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.