Forum Support

 
Advanced Search


[1]

Offline adamsml
Free Member
Posts: 5
Posted on: February 14, 2018, 04:01:39 PM

I'm experiencing an issue with the Outdoor Life template and Internet Explorer for https://www.floridafirefightersafety.org/.

Site visitors using Internet Explorer do not see the menu and the login modal does not work.

In testing with Internet Explorer 11 on Windows 10, I see script errors in the console including:
- Object doesn't support property or method 'remove'
- Unable to get property 'offsetLeft' of undefined or null reference.

As of the date of this post, both the parent and child template have been brought up to the latest version of the Vertex component (4.2.0).

This is an issue for our user base as many visitors are on government networks and using older browsers.
Logged

Offline mikek
Free Member
Posts: 28743 WWW
Posted on: February 15, 2018, 08:47:19 AM

Hello,

I am looking at your site in IE11 and don't see the menu, but I am looking at our demo as well and it is showing with no issues. Have you made any modifications to the template?

Please be sure you are running a default version of the template's index.php file by downloading a fresh copy of the template, extract the index.php file and over-write the existing one on your site.
Logged

Offline adamsml
Free Member
Posts: 5
Posted on: February 15, 2018, 11:41:21 AM

Hello,

I've inherited this site from another developer and there may have been modifications.

In a staging area (not production), I went ahead and overwrote the index.php file in both the parent and child folders.  The menu still does not display. I also changed the default theme to be the parent and had the same issue.

What other steps do you recommend?

Thanks

Mitch
Logged

Offline mikek
Free Member
Posts: 28743 WWW
Posted on: February 16, 2018, 08:49:10 AM

Hello,

If you are positive that you have over-wrote the index.php file the only other thing it could be is an issue with a third party extension. Any extension that causes a javascript can cause other scripts to break. You would need to disable all third party scripts on your site to see if one is interfering. I would probably start with this one:

<script src="/components/com_sppagebuilder/assets/js/jquery.parallax-1.1.3.js" type="text/javascript"></script>

Scripts should not be calling jquery. Jquery is called from the core of Joomla for all products to share so that there are no conflicts on the page. We cannot debug third party extensions.

Keep in mind that the errors you posted are basic javascript commands. This one is not even in our template:

- Object doesn't support property or method 'remove'

This one is but it's a standard call to align the menu:

- Unable to get property 'offsetLeft' of undefined or null reference.
Logged

Offline adamsml
Free Member
Posts: 5
Posted on: February 16, 2018, 10:24:35 AM

Thank you for your help.

An old index.php did appear to be the issue after all. 

Are new release notifications sent when template files change outside of the Shape5 Vertex Framework Updater?

Mitch
Logged
[1]

Jump to:  


Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Page created in 0.02 seconds with 20 queries.
Need some help getting your site up and running? Be sure to check out our tutorials area, post on the forum or hire us
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.