Forum Support

 
Advanced Search


New Posts
FAQs for Wordpress
If you have a question about Wordpress products please read through a list of our most commonly asked questions here.
[1]

Offline dtisi
Free Member
Posts: 16
Posted on: March 19, 2018, 02:16:13 PM

Hello,

I'm trying to use the S5Box widget to open a youtube video in a lightbox. The button to trigger the S5Box is listed on one of the slides in the Image And Content Fader, and when you click on the button on the slide to open the lightbox, nothing happens, the lightbox doesn't open, and there are no error messages that are displayed in the Console tab of Chrome developer tools window.

When moving the button that triggers the S5Box out of the Image and Content Fader slide, it works as intended and opens the youtube video in a lightbox.

You can view the website by going to: https://wp-businessline.mspwebsite.com/
The s5box button in the showcase slider is the following: https://drive.google.com/a/directive.com/uc?id=1XYt9IMk3zJqyv9ec737rM5uIIEWa5RJT
And the example of the button outside of the slider that opens the lightbox can be found here: https://drive.google.com/a/directive.com/uc?id=1-BcO_aVQN7EWKV7dmGSKVLQPNoczlK8i

Can you please advise on the necessary steps to resolve this issue? Thanks!
Logged

Offline Tristan Rineer
Free Member
Posts: 3858
Posted on: March 20, 2018, 09:27:10 AM

I asked one of the designers about what you're trying to do and was told that for displaying YouTube content, you would probably be better off using multibox.  There's a tutorial for multibox in the demo content here: http://shape5.com/demo/wp/business-line/features/vertex-features/multibox-enabled/
Logged

Offline dtisi
Free Member
Posts: 16
Posted on: March 21, 2018, 01:22:18 PM

I had looked into using multibox previously and while using this method does show the youtube video in a lightbox correctly, the lightbox generated is not responsive and has the video content being cut off on smaller screen resolutions and therefore is not really a viable solution in this case.

Is there a specific reason why the s5box widget does not work with the Image and Content Fader widget, and if there is no way get these two widgets working in conjunction with each other, is there a better alternative than multibox?
Logged

Offline Tristan Rineer
Free Member
Posts: 3858
Posted on: March 22, 2018, 10:23:18 AM

I asked the developers that worked on S5 Box about the issue and was told that because of the way the javascript works, S5 Box can't detect links in the slides of the fader. 

I was also told that Multibox can be made to work responsively by just removing the "rel" tag that defines the height and width.

If that doesn't work, a quick search on the WordPress Plugin Repository gave me this: https://wordpress.org/plugins/responsive-thickbox/

I haven't tested it, but it might do what you need.
Logged
[1]

Jump to:  


Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Page created in 0.013 seconds with 21 queries.
Need some help getting your site up and running? Be sure to check out our tutorials area, post on the forum or hire us
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.