Forum Support

Shape 5
January 20, 2022, 01:28:30 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Shape 5 Forum
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: wetaher module again  (Read 214 times)
cokoli
Jr. Member
**
Offline Offline

Posts: 34



« on: November 27, 2009, 12:36:32 AM »

hello, i've posted this in the "weather module" some days ago, but haven't got any response yet, so i'm trying this again:


 I also followed the instructions on how to set up the weather module and I still can't make it display anything else but this pre-written content of the weather.php ...?

see, what i've done:
1) i went to yahoo and located my city (http://weather.yahoo.com/thailand/chon-buri/pattaya-1226081/?unit=c)
2) then i edited the details on .../modules/mod_s5_weather/weather.class.php
     as follows:
 
     $pos = strpos($data, 'yweather:pattaya-1226081');
   $attr = explode('"', substr($data, $pos, strpos($data, '/>', $pos)-$pos));
   $ret[0]['pattaya-1226081'] = $attr[1].', '.$attr[3].', '.$attr[5];
   $ret[0]['when'] = 'Now';
3) then i copied the city code: 'pattaya-1226081' in the admin area of the module

... and then: ... no changes on the page occured

4) ... i found one more 'location' instance on:/modules/mod_s5_weather/mod_s5_weather.php
         so i tried to edit the 'location' in this code as well:
 (   
   echo "<strong>".$ret[0]['pattaya-1226081']."</strong>

";
   foreach($ret as $day)

... and ... still nothing happenning on the frontPage ...

can u please tell me if u have spotted something i'm doing wrong, or what am i missing here?

ps ... i very wanted to use this module also on "elegance" (the city portal and elegance are sitting on the same server, just that the city is in a separate folder and on a separate database, as a subdomain ... in the "elegance" i'm facing the same problem (followed same instructions) as with the city portal ...? i don't think the problem can be caused by a "duplicate" use of the module? ... i tried to remove one of them, but it didn't help, so i uploaded and installed it back again ...
the link to to the city: http://www.city.pattaya-prestigeclub.com/
link to the main "elegance" site: http://pattaya-prestigeclub.com/)

thank you in advance for any idea,
iva
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF | SMF © 2013, Simple Machines
Joomla Bridge by JoomlaHacks.com
Valid XHTML 1.0! Valid CSS!
Looking for the largest variety in template designs? Look no more. Never buy 1 theme again. Signups start at just $89 for access to all of our themes.
Send Us An Email
Please send us your questions and we will email you back as soon as we can. Product support questions should be posted in our support forums under the Help menu. Our staff will assist you from there.